
 

 

Davitche Software Manual for LED Sign  1  

 

lf 

 

 
 

 

 
 

 
 
 
 
 
 

운 

 
  
 
 

 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

Issued on Oct 1, 2012 

 

※ This manual is made base on “DavitChe software(Version 5.5) for 3 color LED sign”, 
but can be applied for the software for the full color LED sign mode”. 
Chapter of “4.3 Video Format Conversion”  is only for the full color LED sign. 
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1. Introduction 
 

This manual is designed to allow a user to understand how to use DavitChe at ease. 

DavitChe is an editing/operating software for DIBD controller which is installed in LED sign board. 

DIBD is an abbreviation of “Display Intelligent BoarD” which can control the LED sign board effectively. 

 

What to do with DavitChe: 
 
 Initially Setting up the communication method, screen resolution/color(BPP), language, etc. 

 Making Contents: Editing text/graphic image, converting video/animation format, Setting up Information 
Text display format(NO.1/2/3). 

 Setting up Playlist: registering contents, setting up display order/effects.... 

 Previewing the display image. 

 Uploading Data to the DIBD. 

 Additional functions: multi-communication set, font change, etc. 

 

 

 

 

 

 

 
  

Fig. 1 Data Flow by DavitChe Software to DIBD controller 
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Versions of DavitChe Software 
 

Version Issued Date Note 

DavitChe Ver. 5.5 2012.09.01  Changed Layout and toolbars of the main screen 
 Modified Information Text setup window and Image Editor  

DavitChe Ver. 5.0 2012.05.01  Integrated software for full/tri color sign  

DavitChe Ver. 4.5 2010.01.01  Applicable only to full color sign software 

DavitChe Ver. 3.3 2009.01.01  Applicable only to 3 color sign software 

 

☞ Versions above are not compatible with each other. 

 

 

 

 

Glossary of Terms 
  

DavitChe Editing & operating software for DIBD controller of LED sign 

DIBD Abbreviation for “Display Intelligent BoarD”. Typed in DIBD120/160/220/260.. 

A controller installed inside LED sign board. 

LED sign or The sign LED sign board 

Content Display files or formats in texts, graphics, videos and others 

Playlist A set of registered contents of which the order/effect/schedule can be set. 

Information Text  Setting format to display analog/digital clock, D-day counter, Temperature, 

humidity.  

  

[text] Button for menus, sub-menus or toolbars 

Tip: Useful notes 

Note:  General notes 

☞ Short or simple notes 

※ References 
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2. Basic Information 
2.1 Installation  
 

System Requirements 
Items Requirements 

Operating Systems Screens 2000/2003/XP/Vista/Win7, Win8  

Interface RS-232, LAN communication 

CPU Pentium IV Processor or higher 

Memory 256MB RAM or higher 

Hard Disk Memory Space Max. 10MB   

Supported Language  Korean, English, Chinese, Japanese, etc. 

 DavitChe software runs only at the Microsoft Windows Operating system. It does not run at Linux, OS X …  
 

Installation 
1. Download the Software file(DavitChe-V5.xxx) from www.davitsol.com. 
2. Unzip the file.  
3. Run “DavitChe.exe” by double-clicking the toolbar below. 

 

Fig. 2 Files of DavitChe Software 

  

http://www.davitsol.com/�
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2.2 Screen Layout  

 

Fig. 3 Layout of Davitche Software 

① Main Menu 

You can execute every function by pressing any of this pull-down menu.(See Chapter 2.3) 

 

② Main Toolbars 

 is to edit text/graphic image files. 

 is to set up display format for information texts like analog/digital clock, D-day, Temperature, etc. 

is to convert the common video file into “*.frm” format.(only for the full color LED sign mode). 

 is to preview the Playlist. 

is to send the data to the LED sign controller(DIBD). 

 is to simulate Message Communication Protocol to/from LED sign controller(DIBD). 

 is to read/display the actual time of the clock inside LED sign by selecting [DIBD 

Online] > [DIBD Time Read]. To correct any time error, click on [DIBD Online] > [Time Synchronization]. 
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③ Toolbars for editing Playlist 

 

 

  

   

 

 

 

 

 

④ Contents Preview Section  

Shows the display image of the contents, clicked by the mouse, on the Playlist. 

 

⑤ Communication Logger 
Shows the communication information between PC and the LED sign controller. 

 

⑥ Version Information Section 
Shows the version information of the LED sign controller.  
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2.3 Menu  

Menu Sub-menu Function 

File 

 

New To make a new Playlist(*.pla).  

Open To open a previously-saved Playlist. 
Add Playlist To add(attach) a playlist to the current playlist. 
Save To save the current Playlist. 
SaveAs To save the Playlist as a new name. 
Save at  
Removable Storage To save the current Playlist file with contents files into a removable disk. 

Exit To exit the program. 

Edit 

Add To add a new line of Content on the Playlist. 

Delete To delete the selected line of Content from the Playlist. 
Modify To modify the selected line of Content(Text Image file only) on the Playlist. 
Copy To add the same Content line below the line selected. 
Up To move the selected line up by one. 
Down To move the selected line down by one. 

System 

ComPort To set up the communication method between PC and DIBD. 

Screen  To set up the LED sign size, the LED display color, the screen configuration direction 
Brightness To set up the brightness of LED sign. 
Power To set up the day/time for power supply of the LED sign. 
Other Setting To set up the language, delete the DIBD memory and test the LED screen condition. 

Temperature 
To compensate the offset value of the temperature sensor and set up ON/OFF value 
for operating fan/heater. 

Contents 

Image Editor To create/edit text image on a simple/divided screen. 
Graphic To open Microsoft Painter to create/edit graphic image. 

Info. Text Format To set up the display format of Information Text : clock/date/time/D-day, Temperature... 

View 
Comm. log To read the communication log between PC and DIBD. 

Preview Playlist To preview the current Playlist. 

DIBD 
Online 

DIBD Upload To upload the current Playlist file, Contents files and parameter files to DIBD. 

Power On To turn on the LED Sign 

Power Off To turn off the LED Sign. 

Time Sync. To synchronize DIBD time with that of PC. 

DIBD Time Read To read the time information from the clock inside the DIBD. 

 

Adv. 

Setup 

DIBD BG Playlist 

Transfer 

To transfer a BackGround Playlist, you can create the BG Playlist which may be used 
as the background image(or preconfigured message) for protocol data packet from  
external system(Server, Imbedded system, PLC, others), and transfer them to DIBD. 

DIBD font 
To display Information text of DavitChe or Urgent/Normal message of external system, 
DIBD requires specific font files. Here you can edit/upload the font files to DIBD. 

DIBD Protocol 
You can simulate the various protocol messages in conjunction with external system. 
Version 5 is for the DIBDs delivered after 04/01/2012. 

Menu Display Set. 
You can enable or disable the menu on the main screen, and setup the size of 
preview screen, for your preference. 

About About You can confirm the information on DIBD/DavitChe version and data folder. 
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2.4 Basic Usage  

 

At DavitChe, you can set up the system preference, create various Content files and a Playlist file, and upload 

them to LED sign controller(DIBD) as the following steps. 

 

① Setup System 

Select [System] > [ComPort] and set up the communication method(Serial or LAN) at “Comm. Set” window.   

Select [System] > [Screen] to set up the screen resolution(Height and Width) and the color(2Bit for 3Color, 

24Bit for full color) at “Screen Set” window, and click on [Send]. 

 

② Create Contents Files 
Click on [Image Editor], and you can create/edit text image files with graphic background image.  

Click on [Info. Text Format], and you can set up the display format for Analog/Digital clock, D-day counter, 

temperature/humidity. 

Click on [Video Converter, only for full color mode], and you can convert the common video file(wmv, avi, 

mov, mp4, gif..) into “*.frm” format for DIBD controller.  

Fig. 4 Main Screen of DavitChe Software 
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Note: When your PC connects to DIBD for the first time, it is recommended to click on [DIBD Online]>[Time 

Sync.] to synchronize the time of LED sign with that of PC, and [Advanced]>[DIBD Font] to transfer font files 

to DIBD. If not, Information Text may not be displayed normally. 

 

③ Making A Playlist 
Import Contents files and set up display order/effect/others and save them as a Playlist file(*.pla).  

3-1. With these toolbars, you can Renew/Open/Add/Save/SaveAs the Playlist file. 

3-2. When you double-click on any cell of Content Name column, a combo box will pop up so that you can 

select the type of Content to import. 

3-3. These toolbars are to edit the contents registered on the Playlist : Add, Delete, Copy, Edit, Up/Down.   

3-4. When you double-click any cell on the right area of the Content Name, a combo box will pop up so that 

you can select options for display effect/speed/time of the content. 

3-5. When you click on  , “Advanced Playlist Set” window will pop up, where you can set up the 

advanced options like Exit effect, Display date/time of each Content. 

 

④ Preview 
When you click on , Playlist Preview screen will pop up and start previewing the Contents with effects, one 

by one, from the selected Content(or top one) of the Playlist. To stop the preview, click on the button again. 

After previewing, click on  to save the current Playlist as a new name(*.pla). 

 

⑤ DIBD Upload  
When you click on  after selecting DIBD address, the Playlist with Contents/Parameter files will be 

uploaded to the DIBD. Once the transmission has completed, LED sign will start displaying automatically. 

When the PC with DavitChe software controls one LED sign only, DIBD00 may be set as DIBD address. But 

when the PC controls more than one, you need to assign DIBD address for each sign.  

If the size of data is too big or the communication does not work well, you can directly copy the data from PC 

to SD(or CF) memory card and insert it to the LED sign controller. 

 

⑥ Content’s Preview : shows the display image of the content, selected by the mouse click, on the Playlist. 

 

⑦ Communication Log : shows the communication information between PC and the LED sign controller. 
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3. System Setup 
Once you have installed the DavitChe, the initial system settings are required as follows. 

Sub-Menu Description 

ComPort To set up the communication method between PC and DIBD. 

Screen  To set up the LED Sign size, the LED display color and the screen direction 

Brightness To set up the brightness of LED Sign. 

Power To set up the day/time for power supply of the LED Sign. 

Other Setting To set up language or execute special functions.  

Temperature 
To compensate the offset value of the temperature sensor and set up ON/OFF value for 
operating fan/heater. 

 

3.1 Communication Setup 
 
Select [System]>[Com. Port] and set up the communication method between PC(installed DavitChe) and DIBD.  

 

3.1.1 Serial Communication Setup 

Serial Communication(RS-232/422/485) can be applied as follows. 

 

① Check Serial Comm.  

② Set up Communication Port. 

Press a combo button  next to Comm. Port and select the 
communication port which is connected to DIBD.   

In order to confirm the Port number, just click on [Device 
Manager]>[Port].  

③ Set up Baud Rate. 
You can select the communication speed(9,600~115,200bps) which is 
the same speed as you have set in the DIBD by Dip Switch. 

④ Click on [Open Port] & [Close Port] to check the port condition.  
If the communication port exists and works normally, you can 
open/close it without any problem and read the status on the Log 
window. 

⑤ Click on [Open Port] & [Close Port] and check the function. If the 
communication port exists and works normally, you can open/close it 
without any problem and read the status on the Log window. 
Click on [Connect DIBD] and check the communication status 
between PC and DIBD. Then DavitChe(PC) will send a “test data 
packet” to DIBD, as below, and DIBD will return the same “data packet” 
to PC. If PC receives the same data packet, DavitChe considers that the communication is normal and shows 
“DIBD Connecting...[OK]” message on the Log window. 
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※ Test Data Packet 
   DIBD Connecting... [OK] 10 02 01 00 0B 6A 30 31 32 33 34 35 36 37 38 39 10 03  
   Receive : 10 02 00 00 0B 6A 30 31 32 33 34 35 36 37 38 39 10 03 

⑥ Signs with multi-communication shall use the address from “DIBD01”, NOT from “DIBD00” 

⑦ Click on [Close]. 

 

3.1.2 LAN Communication Setup 
LAN(Local Area Network) communication can be set as following steps. LAN gateway, which is connected to 
DIBD in the LED sign and set as a server, is always waiting to be connected with DavitChe of your PC which is 
set as a client. When necessary, DavitChe connects to the server, sends the data and cuts the connection again 
for itself. 

 

① Check LAN comm..  

② When using static IP service  
You can connect to the LED Sign by using static IP from private 
network. Refer to Chapter “3.1.4 LAN Gateway Setting”. 

A. Input static IP address of gateway. 
ex.) 192.168.0.201 

B. Input LAN port number which is set in the gateway.  

C. Uncheck the check box of Dynamic DNS.  

When using dynamic IP service 
If you use a router providing Dynamic DNS service, you can connect to 
the LED Sign by using dynamic IP. Refer the router manual for more 
details.  

A. Input the host name of the router which is providing the Dynamic 
DNS service.    
Ex.) hostname.domain.com 

B. Input the port number which is set in the router. 

C. Check the check box of Dynamic DNS. 

③ Click on [Connected]/[Disconnected] to check the connection status between DavitChe(PC) and the 
server(Gateway). When DavitChe fails to connect within 25 second, “Fail” message will appear on the Log 
window.  

④ Click on [Connect DIBD] to check the communication status between PC and DIBD through LAN gateway. 
Then DavitChe will send a “Test Data Packet” to DIBD via LAN gateway, as below, and DIBD will return the 
same “data packet” to PC. If PC receives the same data packet, DavitChe considers the communication to be  
normal and shows “DIBD Connecting...[OK]” message on the Log window. 

※ Test Data Packet 
   DIBD Connecting... [OK] 10 02 01 00 0B 6A 30 31 32 33 34 35 36 37 38 39 10 03  
   Receive : 10 02 00 00 0B 6A 30 31 32 33 34 35 36 37 38 39 10 03 

⑤ Signs with multi-communication shall use the address from “DIBD01”, NOT from “DIBD00” 

⑥ Click on [Close]. 

Note: If the LED sign is connected to an internet router using dynamic IP, you need to check the external IP 
address of the router every time. But if you use Dynamic DNS provided from the router, you can conveniently 
control & manage the LED Sign without frequently checking the dynamic IP as dynamic IP will be automatically 
changed as a name of host. For this application, you need to set the router after registering ID and host name it 
the website(dyndns.org, iptime.org..) which provides the service converting dynamic IP into static IP. See the 
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router manual for setting “Port Forwarding”. 

 

3.1.3 USB Serial Communication Port(Windows XP/7) 
 

When you would like to use a USB serial communication, install USB driver to PC and connect the USB cable to 
PC, and you can confirm the USB Serial Port(COM#) which is automatically assigned by the PC by the following 
steps. 

  
 

Note: From Windows desktop, you can also confirm the port number by selecting [Start] > [System] > 
[Device Manager] > [Port_COM&LPT]. 

 

3.1.4 LAN Converter Setup  
 

LAN Gateway is a module that converts RS-232 protocol to TCP/IP protocol. This enables the device with RS232 
interface to connect to TCP/IP network through Ethernet. Customers can use any product of gateway they like. 
This chapter describes how to set up LAN converter with WIZ110SR of Wiznet company as an example. See 
more details at www.wiznet.co.kr. 

 

 

 

http://www.wiznet.co.kr/�
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Connect the LAN Converter as the figure above, and follow the steps below after supplying power. 

 
① After downloading “WIZ1xxSR_config_v3.zip” file from the website, Install/run “WIZ1xxSR Configuration Tool” 

program. 

② Click on [Search]  and, after seconds, select the LAN Converter on the “Board list”.  

③ Click on [Network] tap, select Static at “IP Configuration Method” and input the number of Local IP, Subnet, 
Gateway. 

④ Select Server at “Operation Mode”. 

⑤ Click on [Serial] tap, set up the parameters. Baud rate should be the same as that of DIBD. 

⑥ Click on [Setting]  and close the program. 

 

 

Note: Refer to the option manual, “How To Set Up LAN Converter”, for more details. 

  

Fig. 5 Setup window of LAN Converter(WIZ110SR) 
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3.2 Screen Setup 
 

Set up the screen size(resolution) and the display color as follows.  
 

① Click on [System] > [Screen] to open “Screen Set” 
window.  

② Input the number of LED modules based on 16x16 LED 
dot matrix.  
Default value is “Height : 2, Width : 6,  2Bit(3Color), 
Horizontal”. 

③ Select Bit Per Pixel : 2 Bit for 3 color, 
color

24 Bit for full 

④ As for the vertical sign, you need set Screen Direction  

. 

to either “Vertical-1” or “Vertical-2” depending on the 
wiring  scheme. Detailed guidance is provided to the 
specific customer from delivery. If not, please keep it at  
“Horizontal”. 

⑤ Click on [Send].  
 

When the communication between PC and DIBD is not 
ready, you can check “Only Set Program” and click on 
[Send]. Then the settings will be applied only to the DavitChe.   

 

 

 

Note: When you see an error message, “Version or BPP(Bit Per Pixel) of DavitChe and DIBD does not match 
with each other”, after clicking on [Send], please check the version of DavitChe and DIBD. Actual DavitChe 
version can be different, depending on the delivery date or purpose of the DIBD. In this case, you are 
recommended to get consultation from the Sign manufacturer. 
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3.3 Brightness Setup  
 
Maximum brightness of the LED Sign depends on the LED modules type and the scan method of manufacturers. 
Set up the brightness in percentage based on the maximum brightness(100%) of the LED. 

By optimizing the brightness of the LED Sign, you can prevent any blurry phenomenon of the LED and extend the 
life span of the LED modules.  

To open “Brightness Set” window as below, click on [System] → [Brightness] from the menu.  

 

Manual Control Mode 
You can set up the brightness of LED Sign in four different time bands of the day. 

① Check Manual. 

② Set up the time band and the brightness for Sunrise, Day, Sunset, Night. 
Ex.) Sunrse(6:00~) : 75%, Daytime(10:00~) : 100%, Sunset(18:00~) : 50%, Night(22:00~) : 25% 

③ Click on [Send]. 
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Auto Control Mode 
When a Photo(CdS) sensor installed, brightness of LED sign will be adjusted automatically by the sensor 
detecting the ambient brightness in the range of preset value(Min ~ Max).  

CdS sensor is a siltoolbar photo type using the Photoconductive effect. When it is exposed to the light, the 
resistance is changed. 
You can set up Auto Control Mode as follows. 

① Check Auto and click on [Send]. 
By clicking on [Send] first, Auto Control mode will be reset. 

② Measure the Min./Max. CDS value. 
When you click on [CDS Read], the actual value will be indicated in the blank next to CDS Value. 
Measure the darkest and brightest value of the day. 
Measure 3~4 times every 3~5 seconds and get the average value. 

③ Input the measured Min/Max. CDS value. 
④ Set up the Low/High value for LED Brightness. 

Low value means the LED brightness to display when CDS measures the Min. value(at Midnight). 
High value means the LED brightness to display when CDS measures the Max. value(at Noon). 

⑤ Click on [Send] to send the settings to DIBD.  
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3.4 Power Setup 
 
You can set up the day, date and time when LED sign screen is turned on/off.  

To open “Power Auto Set” window, click on [System] → [Power] from the menu.  

 

 
Auto Mode 
 
① Check Day of the week when you want to turn on the LED Sign.  

☞ All Day of the week have been checked by default. 
② Set up ‘On Time’ and ‘Off Time’ for days.  
③ Click on [Send] to send the data to DIBD.  

 
 

Manual Mode(By Default) 
 

If you set up ‘On time’ and ‘Off time’ as the same figures, Auto Power Mode will be changed to Manual Power 
Mode.  

Under Manual Power Mode, LED Sign is always turned on. 
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3.5 Other Setup 
Click on [System] → [Other Setting] to open “Other Set” window.  

 

 Program Language Setting 
You can select Korean, English, Japanese or Chinese. If you want to use other language, please contact us 
at davitsol@gmail.com. 

 Display Type of LED Module (Only for DIBD1xx/2xx) 
You can select the “Display Signal Output Method(Scanning Method)” for LED modules in use.  
That may be one of “1/4 Scan, 1/8 Scan, 1/16 Scan”. 
This feature is available only for DIBD120/160 because other types are delivered with fixed method by us. 

 In case of 16x16 LED dot matrix, it can be displayed by not only 1 line, but also 2,4,8 lines simultaneously 
at once. “1/16 Scan” is to display 1 line at a time. “1/8 Scan” is to display 2 lines and “1/4 Scan” is to 
display 4 lines at a time. Scan number means how many lines of LED dot matrix will be turned on at a 
time. The bigger scan number is, the brighter LED Sign will be, but the power consumption will be more.  

 Display type of LED module is different, depending on manufacturers as there is no standard for that. So 
in order to display the image correctly, DIBD requires inserting proper Buffer Board before LED module.  

 The followings are the buffer board types, we provide, for the LED modules made by major module 
manufacturers in Korea. As for the LED modules not shown below, please consult us on how to select the 
buffer board.  

mailto:davitsol@gmail.com�
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Table 1 Buffer Board Type by Scan Method by LED Module Manufacturer 
Duty Buffer 

board 
LED module manufacturer in 

Korea 
Dut

y 
Buffer 
board 

LED module manufacturer  
in Korea 

1/16 
16D-HS Hanse 

1/4 

4D-GP KAPO, Seoul LED 

16D-VS Vissem Electronics, LEDAIS 4D-DV Davitsolution, LEDAIS, Adtronic, Multinet 

1/8 

8D-VS Vissem Electronics,   

8D-GP KAPO, Seoul LED, 
Adtronic (New type), LEDAIS 

  

 

 Delete DIBD Memory File  
You can send a command to delete memory data of DIBD, having two deletion options: “All Files” and “Except 
Video Files”. 
You can also use this command, when the images displayed on LED sign are distorted or overlapped due to 
memory overflow or other reasons.  

 

 Fill Screen (for checking LED display condition) 
You can fill the LED screen with uniform color and check the 
display condition of each LED.  

① Click on any color and [Send] button. Then you will see 
the LED screen filled with the color you selected. You 
can check the display condition of the whole LED 
screen with this function.  

② After the test, please make sure to click on [Playlist 
Setup] and [Send] button again. Then the LED screen 
will be returned to display the image of the current 
Playlist.   

http://www.kapo.co.kr/index.html�
http://www.seoulled.net/�
http://www.vissem.com/�
http://www.leddisplay.co.kr/�
http://www.davitsol.com/main/main.php�
http://www.leddisplay.co.kr/�
http://www.adtronic.com/main.php�
http://multinet.or.kr/�
http://www.vissem.com/�
http://www.kapo.co.kr/index.html�
http://www.seoulled.net/�
http://www.adtronic.com/main.php�
http://www.leddisplay.co.kr/�
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3.6 Calibrating Temperature Sensor 
 

You can install a temperature sensor and display the ambient temperature on LED Sign. 

From the menu, click on [System] → [Temperature], “Temperature Set” window will appear as below.  

 
Now, you can initially calibrate the sensor as follows. 

① Click on [Read Temp] and read the temperature measured. 

② Measure actual temperature by using any precise thermometer, and compare the temperature between the 
two, and input the variation into “Correction Value”, if any. 

③ Click on [Setup Cor.]. 

④ Click on [Read Cor.] to confirm the variation value again. 

⑤ Click on [Read Temp], and you will see the corrected temp. value. 

 

After the hardware setup above, see/follow “4.4.3 Temperature & Humidity” for displaying the value on the sign. 

 

When you install a fan or a heater in the LED sign to turn it on/off at specific temperature, you can set up ‘ON 
Temp’ and ‘OFF Temp’ for automatic control at the blue doted-line above. 
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4. Creating Contents 
4.1 Editing Text Image 
4.1.1 Simple Text Image 

 

① Click on , and the “Image Editor” window will pop up. 
② Input “Hello!! Welcome!!” at Text Input section. 

Tip: If you want to input symbols like “♥♬☎♨@☞㎢”, first write them on Words of Windows and then 
copy/paste them into this Text Input Section. 

③ Set up the text message as follows after selecting them by the mouse left button(click & drag). 
ㆍFont - Arial/Bold, Font size - 10, Text color - Red & Green 

④ Click on  to preview the display image. 
Tip: You can set up the initial size of the Preview Section at [Advanced] > [Menu Display Setup] > [Initial 
Preview Size].  

⑤ Click on  and save it as a new name.     Ex.)2x6-2B-Sample1.dat 
The file shall be saved at “DavitChe/Data/Image” folder by “*.dat” format. 
Note: “2x6-2B-file name.dat” means “2Rowx6Column-2 Bit Per Pixel(for 3 color image)”. 

⑥ Click on , and the Image Editor will be closed and the image file will be added on the current Playlist. 
 
 

Tip: By the multi-language input system(Input Method Editor:IME) of Windows, you can input characters in any 
languages(Korean, Japanese, Chinese and others) at “Text Image Editor” window. For more information, please 
contact us. 

 

  

http://msdn.microsoft.com/en-us/library/ms971336.aspx#input_method_editor�
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4.1.2 Long Scrolling Text 

 

① Click on , and the “Image Editor” window will pop up. 
② Check , and the “Image Editor” window will go to the advanced editing mode. 
③ In order to input the long text scrolling to the left, set up “Horizontal Count for Screen Size” to “5”. 

Note: You can set up the horizontal count up to “9” 
④ Input “Hello! Welcome to New York!!” at Text Input section. 
⑤ Set up the text message as follows after selecting them by the mouse left button(click & drag). 

ㆍFont - Arial/Bold, Font size - 19, Text color - Green & Yellow 

⑥ Click on  to preview the display image. 
Tip: You can set up the initial size of the Preview Section at [Advanced] > [Menu Display Setup] > [Initial 
Preview Size].  

⑦ Click on  and save it as a new name.     Ex.)2x6-2B-Sample2.dat 
The file shall be saved at “DavitChe/Data/Image” folder by “*.dat” format. 
Note: “2x6-2B-file name.dat” means “2Rowx6Column-2 Bit Per Pixel(for 3 color image)”. 

⑧ Click on , and the Image Editor will be closed and the image file will be added on the current Playlist. 
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4.1.3 Text Image on Vertically Split Screen 

 

① Click on , and the “Image Editor” window will pop up. 
② Check , and the “Image Editor” window will go to the advanced editing mode. 
③ Click on , and the Screen Type will 

be the Vertically Split Screen mode. 
④ Check , and the 

following section will pop up. 
 

⑤ Import the graphic image file you want to insert onto the Main/ Screen” section by the following steps. 
A. Click on  at Main Screen section. 
B. When the File Search window pop up, select/import the graphic image file(*.bmp, *.jpg) you have saved 

in advance at “Data/Image” folder. 
C. Then, you can see the image on the Preview section. 
 
Note: You can insert the graphic image on either Main Screen section or Split Screen section.  

Note: You can input texts only on any of the two sections, or input texts on the graphic image inserted. 

⑥ In order to input the long text scrolling to the 
left on Split Screen section, set up 
“Horizontal Count for Screen Size” to “4”.  
Note: You can set up the horizontal count 
up to “9” 
 

⑦ Input “Hello! Welcome to New York!!” at Text Input section. 
⑧ Set up the text message as follows after selecting them by the mouse left button(click & drag). 

ㆍFont - Arial, Font size - 9, Text color – Red /Yellow/Green 

⑨ Click on  to preview the display image. 

⑩ Click on  and save it as a new name.     Ex.)2x6-2B-Sample3.dat 
The file shall be saved at “DavitChe/Data/Image” folder by “*.dat” format. 

⑪ Click on , and the Image Editor will be closed and the image file will be added on the current Playlist. 
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4.1.4 Text Image by Block Input 
You can input text message in several blocks. This feature makes it possible to put each text message block in 
any position on the screen. Here, you will see how to input three blocks(lines) of text messages for a LED 
screen having two lines of LED module(16 x 16 pixels) matrix. 

 

① Check , and “Image Editor” window will go to the advanced editing mode. 
② Check . 
③ Set up “Block Count” to “4”. You can set up the “Block Count” up to “6”. 
④ Input the text message by block as follows. 

A. Input “Hello!” at Block1 section. 
B. Set up the text message as follows after selecting them by the mouse left button(click & drag). 

ㆍFont - Ebrima, Font size - 8, Text color – Yellow 

C. Click on , and you will see the Block1 text message with a red dotted line on the Preview 
section. 

D. In order to locate the message block, click & move the red dotted line to any position you want. 
Tip: You can change the individual block size(red dotted line) by changing the value of  

“X Pos./Y Pos/Width/Height”. 
E. In the same steps above, input text messages for Block2/Block3. 

☞ Each block can be made with text message in different font, font size, font color. 

☞ Whenever you input/change any text of the block, you shall click on  surely. 

⑤ Click on  to preview the display image. 

⑥ Click on  and save it as a new name.     Ex.)2x6-2B-Sample4.dat 
The file shall be saved at “DavitChe/Data/Image” folder by “*.dat” format. 

⑦ Click on , and the Image Editor will be closed and the image file will be added on the current Playlist.  
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4.2 Editing Graphic Image 
 
This chapter describes how to create/convert the graphic image file for the tri-color LED sign. 
 
 
Creating 
 
You can create simple graphic image file by using Painter of Windows, or sophisticated image file by using 
Photoshop, Illustrator, etc., as follows. 

① Set up the same resolution as that of LED sign. 
Ex.) LED sign with 2Rx6C modules(based on 16x16 LED dot matrix) 
    => Height : 32 pixels(2 rows x 16 dots),   Width : 96 pixels(6 columns x 16 dots) 

② Draw a graphic image with pure three colors(red, green, yellow). 
③ Save it as “*.bmp/jpg” format. 

 
 

 
Here is the example for creating a simple graphic image file by using Painter of Windows. 

 
① From DavitChe software, select [Contents] > [Graphic Image] to open the Painter program below. 

 

Fig. 6 Painter of Window 7  

② Create a graphic image in pure tree colors(Red, Green, Yellow and Black).  

 For easier job, click on [View] and check “Gridlines” and “Zoom In”. 

 Select [Home] > [Resize] and set resolution(Width/Height in pixels) of the screen.   
The default value is the same as that of DavitChe screen resolution. 

 Using the various toolbars on the top, draw a simple graphic or text image. 

③ Save the image file at “DavitChe/Data/Image” folder. 

④ Exit the Painter program. 
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Converting 
 
The common graphic file in “.bmp/jpg” format shall be converted into “*.dat” format as follows.  

 

① Click on  to open the “Image Editor” window. 
② Check  to go to the advanced editing mode. 
③ Check  to go to the “BG Image” importing mode. 
④ Click on  at Main/Split Screen section. 
⑤ When the File Search window pop up, select/import the graphic image file(*.bmp, *.jpg) you have saved in 

advance at “Data/Image” folder. And then, you can see the image on the Preview section. 
 
Note: You can insert the graphic image on either Main Screen section or Split Screen section.  

Note: You can input texts only on any of the two sections, or input texts on the graphic image inserted. 

⑥ Check the image size and select the appropriate display mode among the following ones. 
The default mode is “Fit to Screen”. 

 
⑦ Click on  and save it as a new name.     Ex.)2x6-2B-file name.dat 

The file shall be saved at “DavitChe/Data/Image” folder by “*.dat” format. 
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4.3 Converting Video Format(only for full color LED sign) 
DavitChe has a DIFC(Display Image Format Converter) program with which you can import the common video 
file(wmv, avi, mov, mpg, mp4, mpeg…) and convert them to “*.frm” format applicable to LED sign.  
This chapter is to describe how to convert the video file for full color LED sign only. 

 
4.3.1 Preparation  

① In order to run DIFC program, your PC is required to install the following software. 
Please visit the website, download the latest one and install them to your PC in advance. 
 ‘.NET Framework’ and ‘DirectX’ of Windows ( http://microsoft.com/downloads ) 

As for Windows 7, you just need to install ‘Direct X’ as it has ‘.NET Framework(Version 3.5)’. 
 ‘Starcodec’ ( http://www.starcodec.com/en/ ) 

② From DavitChe main screen, click on [video converter] to open DIFC. 
You will see ‘Video Converter’, ‘GIF Converter’, ‘Player’ on the DIFC. 

 

  

http://microsoft.com/downloads�
http://www.starcodec.com/en/�
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4.3.2 Video File Conversion 
Select [DIFC] > [Video Converter] and convert the common video file to “*.frm” format as follows. 
① Set up ‘Target Size(Red rectangular)’ as the same number of pixels as those of LED sign. 

Ex.) LED sign with ‘4 Rows x 8 Columns’ : Width 112(8 x 16 pixels), Height 64(4 x 16 pixels) 
② Set up ‘Source Size(White rectangular)’ about 5 pixels bigger than the Target Size. 
③ Click on the top grey area of the red rectangular and drag it into the white rectangular. 
④ Select [File] > [Video Image] and import the video file to be converted. Then you will see the video image at 

the white rectangular and the video information at ‘Video Information’ section.  
  

Fig. 7 Display Image Format Converter 



 

 

Davitche Software Manual for LED Sign  32  

 

 

⑤ Move the scroll bar from left to right and confirm the video image. Or move the scroll bar to the left end and 
click on [Start Capture] to play the video to see the whole image. 

⑥ Put the scroll bar at the position to start capturing and click on [Start Position]. 
⑦ Put the scroll bar at the position to end capturing and click on [End Position].  
⑧ Click on [Start Capture], and capturing will start.  

Only video image inside the red rectangular will be captured. 
⑨ When the capturing completed, click on [Save File], and the captured video image will be converted into ‘*.frm’ 

format and saved at ‘DavitChe/Data/Video’ automatically. 
⑩ Click on [Exit] to close ‘Video Converter’. 
⑪ Click on [Player], and you can 

open/preview the converted file image 
on the Display Image Format Player as 
shown on the right. 

⑫ After that, close the Player by clicking on 
[Exit].  

⑬ Click on [Exit] to close ‘DIFC’.  
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4.4 Converting GIF format  
 
In order to register any animation file of GIF format on the Playlist, you need to convert them into DIBD 
format(*.frm) by using GIF Converter. Here are the steps to follow. 

① Double click “DIFC.exe” at DavitChe main folder, and “Display Image Format Converter” will pop up. 
In case of a full color software mode, you can just click on  from Davitche to open the converter. 

② Click on “GIF Converter” tap. 
③ Click on [File] and browse/import the GIF file to convert. 

The GIF file will run on “Original Image” area. 
④ In “Converted Image” area, set up the resolution(Width/Height) in pixel.   

Ex.) LED sign with “2 Row x 6 Column” modules : W=96(6x16), H=32(2x16) 
⑤ Click on [Convert], and you will see the converted image in “Converted Image” area and the converted image 

frames in the bottom area. 

⑥ Click on  button and confirm the converted animation image running on Converted Image area. 
The lower FRS number is, the faster running animation will be. 
The lower Boundary number is, the purer three color image will be 

⑦ Click on [Save 2BPP], and the converted image file(*.frm) will be saved at “DavitChe/Data/Video” folder. 
For full color image, click on [Save 24BPP]. 

⑧ Click on [Exit] to close the GIF Converter.  
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4.5 Setting Information Text 
Format 

 

You can set up “Information Text Format” for 
displaying analog/digital clock, date/time, D-
day count, temperature, humidity.  
Select [Contents] > [Info. Text Format] or 

just click on  to open “Information Text 
Set” window. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig. 8 Components of Information Text Setup Window 

Division Description 

.①Information 1,2,3 You can set up to three forms of Information Text and register each of them on a Playlist. 

Analog clock can be set at “Info.1” only, D-day counter at “Info.2” only, while a background 

image file can be attached to “Info.2&3”.  

.②Section 1,2,3,4 Each Information Text has four sections.  

.③Horizontal/Vertical 

Position 

You need to set up the Horizontal/Vertical start position of the section.  

The position can be set by four pixels from the top-left end. 

.④Font You can set up the font size in four pixel-unit from 12x12 to 64x64.  

Hangul font size is the same as the nominated one(Width x Height in pixel), while ASCII 

character size(alphabet, numeral) is half of that in width. 

. ⑤Code You can select various information text codes. For details, refer to the code table below.  

. ⑥Code Color You can set up the each color of the code. 

. ⑦Analog Clock You can set Analog clock displayed on “Information Text 1”.  For details, see “Chapter 4.4.4”  

. ⑧Preview On the setting process, you can preview the Information Text by clicking on [Preview] button. 

. ⑨File Managing tools [Send] is to send the set values(parameters) to DIBD. 

[Open] is to open the previous saved file(*.isf).  

[Save]/[SaveAs] is to save the current Info. Text set file(*.isf) at “DavitChe/Sys” folder. 

[Clear] is to clear the set values of the current Info. Text set window. 

. ⑩Info. Text File Path To show the current Info. Text file & path. 
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Table 2 Codes of Information Text 

NO. Code Description Format NO. Code Description Format 

1 YYYY Year 2011 17 JAN-DEC Month of the year JAN ~ DEC 

2 YY 
Year,  

Showing “0” at 10-digit. 
01 ~ 99 18 ‘-‘   Hyphen -  

3 MM 
Month,   

Showing “0” at 10-digit 
01 ~ 12 19 ‘:’ (On) Colon :  

4 M 
Month,  

Not showing “0” at 10-digit. 
1 ~ 12 20 ‘:’ (Blink) 

Colon with blinking 

It blinks every second. 
: (blinking) 

5 DD 
Date,  

Showing “0” at 10-digit. 
01 ~ 31 21 ‘ ‘Space Giving a blank space Blank 

6 D 
Date,  

Not showing “0” at 10-digit. 
1 ~ 31 22 / Diagonal line / 

7 24H-HH 
24-hour clock,  

Showing “0” at 10-digit. 
00 ~ 23 23 ℃-XX Temperature in Celsius  XX 

8 24H-H 
24-hour clock,  

Not showing “0” at 10-digit. 
0 ~ 23 24 ℃-XX.X 

Temp. in Celsius with one 

decimal digit 
XX .X 

9 12H-HH 
12-hour clock,  

Showing “0” at 10-digit. 
01 ~ 12 25 ℃ Symbol of Celsius  ℃ 

10 12H-H 
12-hour clock, 

Not showing “0” at 10-digit. 
1 ~ 12 26 ℉-XXX Temperature in Fahrenheit  XXX 

11 NN 
Minute, 

Showing “0” at 10-digit. 
00 ~ 59 27 ℉-XXX.X 

Temp. in Fahrenheit with 

one decimal digit 
XXX .X 

12 N 
Minute, 

Not showing “0” at 10-digit. 
0 ~ 59 28 ℉ Symbol of Fahrenheit ℉ 

13 SS 
Second, 

Showing “0” at 10-digit. 
00 ~ 59 29 ‘%-XX Humidity  XX 

14 S 
Second, 

Not showing “0” at 10-digit. 
0 ~ 59 30 ‘%-XX.X 

Humidity with one decimal 

digit 
XX .X 

15 AM/PM AM or PM AM, PM 31 % Symbol of humidity % 

16 SUN-SAT Day of the week SUN ~ SAT 32 D-Day days of “today – D day” XXXXX 
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4.5.1 Date & Time  
You can set up the current time and date displayed on the LED sign at the format of Information1/2/3. 

1. Click on  from Davitche software to open “Info. Text Format Set” window. 

 
2. Select [Information1] and set up the parameters, as follows, in yellow area. 

 

① At Section1, click on the individual combo button in yellow area and set up the parameter for date display. 

② At Section2, click on the individual combo button in yellow area and set up the parameter for time display. 

③ During the setting process, click on [Preview] to confirm the display image of the Info. Text you have set. 

④ If necessary, click on [SaveAs] to save the format as a new name(*.isf) at “DavitChe/Sys” folder. 
☞If not, the format will keep the last set values unless you click on [Clear] button.  
☞When you click on [Clear], the values of the format will be initialized.    

⑤ Click on [Send] to send the set values to DIBD. 
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3. Register [Info. 1] at Playlist setup area and send the Playlist file to the sign controller as following steps. 

 

① Click on    . 

② Double click on the blank area of Content Name to open a “file type selection box”. 

③ Select  “Info.1“. 

④ Click on , and a preview window will pop up to show the display image. 
To close the preview window, just click on the toolbar again. 

⑤ Click on  to save the current Playlist file as a new name at “DavitChe/Data/Playlist”. 

⑥ Click on  to send the file to the sign. Once the transmission is over, the image will be displayed on 
the sign.  

 

Note: If the data/time is not correct, select [DIBD Online] > [Time Synchronization].(See Chapter 7.3) 

 

Note: If any figure is not displayed on the LED sign, select [Advanced] > [Font Transfer] and transfer the font  
      files for information text.(See Chapter 8.2) 

 

 

 

Fig. 9 Example on How To Divide the Sections by Pixel(Xstart, Ystart) 
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4.5.2 D-day 
You can set up the D-day counter at the format of Information2 only. 

1. Open Image Editor by clicking on  and create a text image file, as follows, and save it as a new name at 
“Davitche/Data/Image” folder. (For example: “2x6-2B-Sample5.dat”) 

 
☞ Font - Arial, Font size - 10, Bold, Font color – Yellow/Red.  

☞ For details, refer to Chapter 4.1.1. 

2. Click on  from Davitche software to open “Info. Text Format Set” window and set up as follows. 
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① Select “Information2” tab. 

② Select “Background Image” tab, click on  and import the file you have created as above. 

 
When you click on [Preview], you can confirm the display image of the imported file. 
Note: Any file in “*.dat”, “*.bmp/jpg” format can be imported as a background image. 

③ Select “D-Day Setup” tab and set up the due date you want.  

④ Set up Section1 of Information2

⑤ Click on [Preview]. 

 as ;. 
☞ Horizontal Position - 28 Pixel, Vertical Position - 16 Pixel, Font - 16, Code - D-Day, Code Color – Red 

☞ The rest of the Codes shall keep “None(Default)”.  

⑥ Click on [Send] and [Close]. 

 

3. Register [Info. 2] at Playlist setup area and send the Playlist file to the sign controller as steps in Chapter 
4.5.1(3). 

 
Note: When D-day is not correct, you are recommended to click on [DIBD Online] > [Time Sync.]  

to synchronize the time of LED sign with that of PC.(See Chapter 7.3) 
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4.5.3 Temperature & Humidity 
You can set up the display format for Temperature & Humidity at Information2/3 as follows. 
The sensor is delivered as an option. 

1. Open Image Editor by clicking on  and create a text image file, as follows, and save it as a new name at 
“Davitche/Data/Image” folder. (For example: “2x6-2B-Sample6.dat”) 

 

☞ Font - Microsoft New Tai, Font size - 9, Bold, Font color – Yellow.  

☞ For details, refer to Chapter 4.1.1. 

2. Click on  from Davitche software to open “Info. Text Format Set” window and set up as follows. 
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① Select “Information3(or Information2)” tab. 
Note: Information1 is not allowed to insert a background image. 

② Select “Background Image” tab, click on  and import the file you have created as above. 
When you click on [Preview], you can confirm the display image, as 
right, of the imported file.  
Note: Any file in “*.dat”, “*.bmp/jpg” format can be imported as a  
background image. 

③ Set up Section1 of Information3
☞ Horizontal Position - 40 Pixel, Vertical Position - 0 Pixel, Font - 16, Code – ’C-SXX.X/’C, Code Color – Red 

☞ The rest of the Codes shall keep “None(Default)”.  

 as ;. 

④ Set up Section2 of Information3

⑤ Click on [Preview]. 

 as ;. 
☞ Horizontal Position - 48 Pixel, Vertical Position – 16 Pixel, Font - 16, Code – %-XX.X/%, Code Color – Red 

⑥ Click on [Send] and [Close]. 

 

4. Register [Info. 3] at Playlist setup area and send the Playlist file to the sign controller as steps in Chapter 
4.5.1(3). 
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4.5.4 Analogue Clock  
You can set up the display format for analog clock only at Information1. 

Several kinds of animation files for analog clock are provided on your request. 

 

1. Click on  from Davitche software to open “Info. Text Format Set” window and set up as follows. 

 

① Select “Information1” tab. 

② Import the analog clock file as follows. 

 Click on  and import the file, “2x2-Clock-32x32-180-2-N.frm”, saved at “DavitChe/Data/Video”. 
Note: You can choose to use any analog clock file in “*.frm” format among “2x2-, 3x3-, 4x4-“. 
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 Set up as “Analog Clock Display - Enabled, Horizon Pos. - 8 Pixel, Vertical Pos. - 0 pixel”. 

 Click on [Send]. 

  [Preview].  

③ Set up Section1 of Information1

④ Set up 

 as ;. 
☞ Horizontal Position - 48 Pixel, Vertical Position - 0 Pixel, Font - 16, Code – YYYY, Code Color – Green 

☞ The rest of the Codes shall keep “None(Default)”.  

Section2 of Information1

⑤ Click on [Preview]. 

 as ; 

☞ Horizontal Position - 44 Pixel, Vertical Position – 16 Pixel, Font – 16, Code – MM,/,DD, Code Color – Red 

⑥ Click on [Send] and [Close]. 

 

2. Register [Info. 1] at Playlist setup area and send the Playlist file to the sign controller as steps in Chapter 
4.5.1(3). 
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5. Making Playlist 
At Playlist Setup section, you can register various contents, and set up display order/effects/schedule and save 
them as a Playlist file(*.pla). 

5.1 How To Make a Playlist  

 

① Click on   [New] to reset the Playlist Setup section.  
☞ If you want to open a previously saved Playlist file, Click on   [Open]. 
☞ If you want to add Contents of any Playlist to the current Playlist, click on   [Add Playlist]. 

② Double click on the blank cell of Content Name. 

③ Select Contents type(Ex. Image) from the popped combo box.  

Contents Type Description 

Image 
ㆍYou can import Text or Graphic image file(*.dat) from “DavitChe/Data/Image” folder.  

This can be created/edited by Image Editor(See Chapter 4.1/4.2). 

Video 
ㆍYou can import to register Video file(*.frm) from “DavitChe/Data/Video“ folder.   

This can be converted by DIFC.(See Chapter 4.3/4.4) 
Info.1/2/3 ㆍYou can register Information Text Format number which you have set in advance. 
Message ㆍThis is used only for displaying protocol message from external system. 

④ Search and open the Content file you wish to display.   Ex. 2x6-2B-Sample1.dat 
☞ “2x6-2B-” indicates “content files for LED sign in 2 Row x 6 Column - 2 Bit Per Pixel(3 Color image)”. 
☞ “2x6-24B-” indicates “content files for LED sign in 2 Row x 6 Column - 24 Bit Per Pixel(Full Color image)”. 
 

 

⑤ Click on [Add] to add a line for another Content.  
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⑥ Repeat steps “②~⑤” and register all the contents 
you want.   

⑦ Click on [Playlist Preview] after clicking on  any 
Content name. 
Preview screen will pop up, as shown on the right, 
and start displaying images sequentially from the 
content you selected.  When you click on [Playlist 
Preview] toolbar without selecting any Content name, 
Previewing will start from the first Content name. 
☞ To stop Preview, click on the [Preview] again. 
 

 

⑧ When you double-click cells on the right area of the Content Name, combo boxes will pop up, where you can 
select options for display effects, speed, time, etc. Furthermore, when you click on , “Advanced Playlist 
Set” window will pop up, where you can set up the advanced display effects.  
For details, see Chapter 5.2/5.3. 

 
⑨ Edit the Playlist by using the below toolbars. 

Toolbars Description 

 [Add] To add a line below the clicked(selected) Content name. 

 [Delete] To delete the line you clicked. 

 [Copy] To copy a line below the selected Content name. 

 [Modify] To open Image Editor to edit the image file selected. 

 [Up]] To move the selected Content up a line. 

[down] To move the selected Content down a line. 

[Adv. set] To open “Advanced Playlist Set” window 

⑩ Click on [SaveAs] and save the Playlist file as a new name(*.pla) at “DavitChe/Data/Playlist” folder. 

⑪ Click on  to preview the final display image of the Playlist. 

⑫ When you click on after selecting DIBD address, the Playlist including Contents/setting files are sent to 
the DIBD. Once the transmission has completed, LED sign will start displaying automatically. 
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5.2 How To Set Up Display Effect 
You can set up various display effects to each Content. 

The available effects depend on the selected content type or the screen type. 

Note: When the image file(content) is created in the divided screen, you can set up Div. Effect/Direction also for 
its divided section. The screen mode can be set up at [Image Editor] > [Advanced Edit] > [Screen Type]. 

 

① Double click on any cell of MainEffect column and set up the entrance effect of the content for main screen.  
Table 3 Appearing Effect and Direction of the Content 

Effect Direction Description 
Stop NoDir No Effect 

BrightON Brightness to be increased from 10 to 250 relatively. 
BrightOff Brightness to be decreased from 250 to 10 relativel. 
HoriMirror To display a normal image and a horizontally reflected image(by a mirror), 

five times alternately. 
VertMirror To display a normal image and a vertically reflected image(by a mirror), 

five times alternately. 

Random Sequential  
Random To display the image by randomly selected effect of all. 

Shift Left 

To display the image scrolling to the direction. 
Right 
Up 
Down 
Up&Down To display the image scrolling up & down twice. 
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Wipe Left 

To display the image writing on the screen to the direction. 
Right 
Up 
Down 

Blind Left 

To display the image like opening the blind to the direction.  
Right 
Up 
Down 

Curtain Hori.Side 

To display the image like opening the curtain to the direction 
Hori.Center 
Vert.Side 
Vert.Center 

ZoomOut Left 

To display the image being reduced to the direction. 
Right 
Up 
Down 
Left Up 

ZoomIn Left 

To display the image being enlarged to the direction. 
Right 
Up 
Down 
Right Down 

Rotate Counter To display the image rotating to the direction.  
Clockwise 
Counter2 To split the image into two vertically and rotate them to the direction. 
Clockwise2 

Blink B.G. Red 
To blink the background with selected color. Green 

Yellow 
All To blink the background with all colors one by one. 

Blink Text Red 
To blink the selected color of the text to highlight. Green 

Yellow 
All To blink all the color of the text one by one. 

3D Effect Left To rotate the text to the left with three dimensional effect. 
Test 
(LED Screen) 

Left 
To display LED bars moving to the direction on LED screen. 
With this function, you can visually check the LED display condition. 

Right  
Right down 

Note: Text image(*.dat) longer than the screen size(width) will be automatically set by the Exit Effect of 
shifting to the left. When you click on  [Advanced Playlist Setup], you can change the Exit effect also. 

 

② Double click on the cell of Direction column and set up the direction for Main Entrance Effect. 
Options for Direction are different depending on the kind of effect. 

③ Double click on the cell of Div.Effect column and set up the entrance effect of the content for the divided 
screen. This effect will be applied only to the divided screen section. 

④ Double click on the cell of Direction column and set up the direction of entrance effect of the content for the 
divided screen. 

⑤ Double click on the cell of Speed column and set up the effect speed. 

⑥ Double click on the cell of Stay Time column and set up the stay time of the content after entering to the 
screen. 
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Note: When you click on     , “Advanced Playlist Set” window will pop up, where you can set up Exit Effect,  
Display Time. 

  

5.3 How to Set Display Time 
You can set up the time on which any specific content will be displayed or not. If not, each content on the Playlist 
will be always displayed sequentially & repeatedly by default.  

 

① Click on    to open “Advanced Playlist Set” window. 

② Double click on any cell of the content below Display Time to open “Display Time Set” window. 
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③ You can uncheck any specific Day of the week on which you do not want to display the Content, and vice 
versa. 

 The default is to keep all days of the week checked(√).  

 On unchecked

④ Set up ON/OFF time, if necessary. 

 day of the week, the LED sign will not display the content regardless of the ON/OFF Time 
setup below. 

 When both ‘ON time’ and ‘OFF time’ show the same current date & time(like Case 2), the Content will be 
always displayed. This is the default. 

 If you set all the digits to “00”(like Case 1), the Content will be always displayed also.  

 If you set Date/Hour/Minute while setting Month to “00”(like Case 3), the Content will be displayed every 
month

 If you set Hour/Minute while setting both of Month and Date to “00”(like Case 4), the Content will be 
displayed 

 during the period of the set date/hour/minute. 

every day
Table 4 Cases of ON/OFF time 

 during the period of the set hour/minute. 

Cases 
On Time Off Time 

Display time 
M D AM/PM H M M D AM/PM H M 

1 00 00  00 00 00 00  00 00 Always 

2 01 12 AM 12 28 01 12 AM 12 28 Always 

3 00 10 AM 08 30 00 20 PM 12 00 08:30 10th ~ 12:00 20th Every Month 

4 00 00 AM 06 00 00 00 PM 12 00 06:00 ~ 24:00 Every day 

5 05 01 AM 08 30 10 15 PM 06 30 08:30 01st May. ~ 18:30 15th Oct. 

6 11 01 AM 08 30 05 31 PM 12 00 08:30 01st Nov. ~ 24:00 31st May. 

 

⑤ Click on [Apply] to upload the setting parameters to DIBD.  
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6. View 

 
6.1 Reading Communication Log 

From the main menu, select [View] > [Comm. Log], and you will see “Communication Log View” window, as 
below, where you can read the communication log between DavitChe(PC) and LED sign controller. 

This can be useful for a user to monitor the system and troubleshoot any problem. 

 

 

DavitChe software keeps the log for 
the last 7 days by default.  

However you can change it for your 
preference. 

 

“Save Auto” shall be checked as 
usual. 

 

Click on [Save Log], and you can 
save the current log(*.log) at 
“DavitChe/Log” folder. 

Click on [Open Log], and you can 
open to read the saved log files. 

 

You can also open the log file at 
Notepad. 
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6.2 Previewing of Playlist 
During or after setting up the Playlist, you can preview the contents on the Playlist as follows. 

 

① Click on any cell of Contents Name to start Preview. 

② Click on [Preview Playlist]. 

③ Then you can preview the Contents with effects starting from the selected Content Name sequentially and 
repeatedly.  

 To stop the preview, click on the toolbar again. 

 If you click on [Preview Playlist] without clicking on any Content Name, it will start from the 1st line of the 
Playlist. 
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7. DIBD Online  

 
7.1 DIBD Upload  

After you set up and save the Playlist, click on [DIBD upload], and the Playlist with Contents/Parameter 
files will be uploaded onto DIBD. 

Once the transmission has completed, LED sign will start displaying automatically. 

 

7.2 Power On/Off 
When you select [DIBD Online] > [Power ON/OFF], you can check the function of turning on/off the LED screen, 

 

7.3 Time Synchronization 
When you select [DIBD Online] > [Time Sync.], PC will synchronize the time of LED sign. 

You are recommended to do this when you first connect with LED sign , or once a month, or when applying 
for the Summer time and so on. 

 

7.4 DIBD Time Read 
When you click on [DIBD Online] > [DIBD Time Read], Davitche software of your PC will read the date/time data 
from the clock installed in the LED sign controller(DIBD) and display on the section below with an arrow mark. 

 
Note: If the data/time is not accurate, you are recommended to follow Chapter 7.3 or change the rechargeable 
battery. 
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8. Advanced Setup 

 

8.1 DIBD BG Playlist Transfer 
When you save the Playlist to send it to the LED sign controller, you have two options, depending on the 
application, “the typical Playlist file(*.pla) and the Background Playlist(*.bgp).” 
If you save it as BG Playlist(*.bgp), you can use it as the background images(or directly display images) for the 
following cases: 

[Case 1] As for the protocol LED sign, you can assign one of the numbers of BG Playlist to any protocol 
message coming from external system(Ex. Web server, imbedded system and so on). So the 
protocol message(mostly in simple text) can be displayed on the assigned background image. 

[Case 2] As for the LED sign for displaying PLC(Programmable Logic Control) message, you can create 
contents(mostly in text or graphic image) and register them onto the BG Playlist(*.bgp) in order. So 
LED sign can directly display the content corresponding to the number of Switching Signal coming 
from external PLC(Programmable Logic Control). 

[Case 3] As for the general LED sign, you can assign one of the numbers of the BG Playlist(*.bgp) to any 
content of Playlist(*.pla) to be used as the background image.  

This chapter is to describe how to make a BG Playlist(*.bpg) and apply for Case [2] as an example. 

 

Fig. 10 Block Diagram of LED Sign Board for Displaying PLC Switching Signal Message 

At DavitChe software, you can create messages to display on LED sign, register them in a BackGround Playlist 
file in order, and upload them onto DIBD. 
8 bits of switching signal(00000000~11111111) can be made by 8 pieces of relays or PNP/NPN signals of PLC. 
When DIBD receives a switching signal from PLC, the LED sign will display the registered number of messages 
(#1~255) on BG Playlist in an orderly manner: “00000001” will display “Message #1 ”, “00000010” “Message #2”, 
and similarly on up to “11111111” with “Message #255”.  
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When receiving no signal(00000000), the sign can be set to display general message(ad, data/time, information, 
etc.). 
 
Now, let’s see how to create Contents, make a BG Playlist and upload them to DIBD.  

1) Creating Contents(Text Message Files) 
At Davitche software, click on  to open Image Editor window and create the number of text message files 
for the PLC switching signals. 

 
 

☞ For details, refer to Chapter 4.1.1. 

☞ Save all the message files at “Davitche/Data/Image” folder.  
 
 

Note: The message can be created in graphic files(bmp, jpg) also by using graphic tools such as Painter 
program, Photoshop, Illustrator and so on. For details, refer to Chapter 4.2. 

 
2) Making a Background Playlist(*.bgp) 

 

① Click on [New Playlist]. 
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② Double click on the blank cell below Content Name. 

③ Select Image from the combo box for content type. 

④ Import the message file that you want to display for number 1 switching signal from PLC.  
Ex.) 2x6-2B-Message01.dat 

 

⑤ Click on [Add] to add a lines for registering another content file. 

⑥ Repeat steps “②~⑤”  above and register all message files you have created. 

⑦ Double click on the cell on the right area of each content file name, and set up the display 
Effect/Speed/StayTime/etc for your preference. (Refer to Chapter 5.2)  

Note: Effect for longer text message than LED screen size will be set to “Shift to Left” by default. 

Exit Effect can be set by clicking on [Advanced Playlist Set]. 

⑧ Click on [Playlist Preview] to confirm the display image of each content with effect. 
In order to stop Preview, click on the toolbar again. 

⑨ Click on [SaveAs].  

⑩ Select BG Playlist(*.bgp) for file type.  

⑪ Save it as a proper name. 
Ex.) 2x8-plc sample.bgp 

⑫ Click on [Save], and the file shall be 
saved at “DavitChe/Data/Playlist” folder. 
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3) Uploading The BG Playlist 

 

① Select [Advanced] > [DIBD BG Playlist Transfer], and “DIBD BG Playlist Transfer” window will pop up 
and show the previously saved BG Playlist file in the file path box by default. 
If not shown, you can click on [browse] and import the file(*.bgp) for yourself from 
“Davitche/Data/Playlist”. 

② Click on [Send] to transmit the BG Playlist to the flash memory in DIBD. 

 
 
Now! 
It’s ready for the LED sign to display any text message corresponding to switching signal coming from 
PLC. 
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8.2 DIBD Font Transfer 

In order to display Information Text(Date/time, D-day count, temperature..) or the protocol messages from 
external system, it is necessary to upload the special font files to DIBD as follows. 

 

① Select [Advanced] > [DIBD Font], and “DIBD Font Transfer” window will pop up. 

② Click on the 1st [Browse] and import the font file(“DVS-ENG08x16-Gothic.fnt” recommended) from 
“DavitChe/Sys/Font” folder. 
☞ “ENG08x16- “ indicates the font file for English characters, numbers and ASCII symbols in the size of 
08Widthx16Height pixels. 

③ At the 2nd /3rd font selection box, you can select other language font or User font. 
This is set from the delivery. But you can change the font in consultation with the sign company. 

④ Click on [Send], [Close]. 
 

※ Type of Font Files used at DavitChe     
☞ These files are at “DavitChe/sys/font”. If necessary, you can edit them by using any font editing program you use. 
A. ENG08x16(pixels)-  is to display English characters, numbers, or ASCII symbols. When receiving any 

hexadecimal code between 0x0000 and 0x007F, the DIBD will display the corresponding font among 
these. 

B. KOR16x16- is to display Korean characters in Combination font. When receiving any code between 
0x8861 and 0xD3BD, the DIBD will display the corresponding font. However, when receiving 
Completion font code between 0xAC00~0xD7A3, the DIBD will convert it into Combination font code 
and display it by Combination font among these.  

C. User16x16- is to display special characters or symbols created by user. When receiving any code 
between 0xE000 and 0xE0FF, the DIBD will display the corresponding font among these. User can 
develop various fonts by using a font editing program(ex. Fontman.exe) at the size of 16x16 pixels. 

D. UNI_ALL-16x16 includes the following Unicode fonts. When receiving any code among the followings, 
the DIBD will display the corresponding font. 
 .0x0000~0x007F for ASCII(English, figures)          
 .0x3040~0x30FF for Japanese characters 
 .0x4E00~0x9FFF for CJK common Kanji 
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Note: As the DIBD supports Unicode also, it is possible to display most of texts in Chinese, Japanese, 
Arabic, etc. Unicode has more than 60,000 fonts and requires big memory capacity(2MByte based in 
16x16 font). So we provide a SD memory saving Unicode fonts only when requested from customer.  

 

8.3 DIBD Protocol Simulation 

The sign displaying data coming from the external system(Server PC, PLC, Embedded System, Measuring 
devices, etc.) is named as the Protocol Sign Board or the Server Interfaced Sign Board. The data is transmitted 
in real time or on a regular basis, and the data must be made in the type of protocol that can be recognized by 
the sign’s controller. 

The protocols of the sign do not have international standards yet, so every company manufacturing controllers 
has different protocols that are not understandable at ease and have different level of display functions. 

If you get to know the protocol of DIBD 
and use it, you can display any type of 
texts or images on the sign board 
effectively. 

DIBD Protocol Simulator has been 
designed for external system engineer to 
understand the DIBD protocol easily and 
to efficiently develop their data 
transmission protocol.  

With the simulator, you can do the 
followings.  

 

1. You can try to input any text 
message you want to display, 
change various parameters and 
preview the display image on 
Preview screen. 

2. You can  read the actual 
transmission protocol packet(codes) 
for the display image at Log window 
of DavitChe. 

3. Through this simulation, you can get 
the best message protocol packets 
and apply them to the  data 
transmission protocol program for external system. 

 

For more details, please refer to “DIBD Protocol Manual” from our website(www.davitsol.com). 

 

 

  

http://www.davitsol.com/�
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8.4 Firmware Upgrade 
If you want to upgrade the firmware of your controller, you can do it as follows in consultation with the LED sign 
supplier. This function shall apply only to the controller which delivered after Jan. 2013. 

① Get the firmware file from the supplier and save it on your PC. 
File example) DIBD260P_3C_4R16C_V05.31_CDS_TEMP_GPS_OUT2_DS1302_IN8-FAT.bin 

② Run the Davitche software. Your PC shall be connected with the LED sign controller. 

 

③ Select  [Advanced] > [Firmware Upgrade], and a Windows Search window will pop up. 

④ Import the firmware file you have saved. 

⑤ Confirm the version information of the imported firmware file. 

⑥ Click on [DIBD Read] to confirm the version information of the current firmware file installed in the LED 
sign controller. 

⑦ Click on [Send] to upgrade the firmware file with new one. 
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8.5 Menu Display Setup 
You can make each toolbar/menu on the Davitche software appeared or disappeared, or change the initial 
preview screen size, for your preference. 

For this, click on [Advanced] > [Menu Display Setup], setup the below items of the section what you want and 
click on [Apply]. 

 

 
[ Section Description ]  

 

A. “Select Menu Group” is to select the menu display option which are grouped by default. However, you can 
change the individual menu option also after selecting any group. 

B. “Select Menu Bar” is to set up the display option of the top-full-down-menu. 

C. “Playlist Setup” is to set up the display option for the menu in the Playlist Setup section. 

D. “Others” is to set up the display option for the menu for special purpose. 

E. “Initial Preview Size” is to set up the initial screen size for “Main Preview”, “Contents Preview”, “Text Image 
Editor”. 
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9. Product Information  

When you click on [About] menu, you will see the information of the 
hardware or software of your product in use on the section of Product 
and Folders. 

 

 Production Information 
Click on [Product Info.] tab and then [Ver. Read] button, and you will see 

the DavitChe version and the DIBD information connected as the follows. 

 
 
 
※ How to Read Version Information of DIBD 

Ex.) [DIBD500P]-02x006-03-SD V05.42, 2013-07-15 

 

Mark Description 

.DIBD①②③④ “①②③” indicates DIBD models: DIBD120/160/220/260/500   

“④” indicates the message sources;  

P is for displaying Protocol messages transmitted from external system(Web server, 

imbedded system, PLC, measuring devices..) and N is for displaying Normal LED sign 

messages created/edited at DavitChe of PC. 

Ex.) “DIBD500P” indicates DIBD500 controller for displaying Protocol message. 

.⑤⑥x⑦⑧⑨ “⑤⑥” indicates the number of vertical(Row) modules(16x16). 

“⑦⑧⑨” indicates the number of horizontal(Column) modules.  

Ex.) “02x006” indicates “2 Rows x 6 Columns” of LED modules. 

.⑩⑪⑫ “⑩⑪” indicates the number of DIBD address in hexadecimal on multi sign control. 

“⑫” indicates the communication speed between PC and DIBD.  

( 0=9,600bps, 1=38,400bps, 2=57,600bps, 3=115,200bps ) 

Ex.) “B3”  indicates DIBD address “11(BHEX)” with 115,200 bps. 

.SD “SD” indicates that DIBD is equipped with SD(or CF) memory card.   

.Vxx.xx “Vxx.x” indicates the DavitChe version in use. 

.Date Manufacturing Date of the controller. 
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 Folder Information 
Click on [Folder Info.] tab, and you will see the folder information as follows.  

 
 
Note: “Information Text File(*.isf)”, and “DIBD multi-communication setup file(*.ssf)” can be saved at “DavitChe/Sys” 
folder.  
 
 

Classification Files type to be saved. 

Playlist  Playlist(*.pla) 
 Background Playlist(*.bgp) 

Image  Text/Graphic Image(*.dat) 

Video  Video/Animation(*.frm) 

Font  Font(*.fnt) 

Log  Log(*.log ) 
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10. Saving Data At Removable Storage  

 

This chapter is applicable only to the DIBD equipped with SD/CF memory. 

 

DIBD for full color display equips with the CF memory card by default, while DIBD for tri color display can be 
equiped with them as an options. 

  
When Playlist includes big size of video files, it may take long hours to upload them to DIBD through Serial/LAN 
communication. In order to save the time, you can directly copy the data of your PC to SD/CF memory of the 
DIBD as follows.  

 

① Save the current Playlist file at Davitche software, and the Playlist file(*.pla), content files(*.dat/frm) and 
parameter files(*.set) will be saved at “Davitche/Memory” folder automatically. 

② Power off the DIBD of LED sign. 

③ Take out SD/CF memory from the DIBD and insert it to the memory reader slot of your PC. 

④ Click on [File] > [Save at Removable Storage], and data at “Davitche/Memory” folder will be copied to the 
SD/CF memory. 

⑤ Take out the SD/CF memory from the memory reader slot and Insert it to the slot of DIBD again. 

⑥ Power on the DIBD, and LED sign will start displaying the image. 
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